1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

TLS/SSL/HTTPS

Discussion in 'Site Questions, Suggestions and Discussions' started by Coco, Feb 12, 2017.

  1. Coco

    Coco New Member
    Contributor

    Joined:
    Feb 11, 2017
    Messages:
    8
    Likes Received:
    1
    This website should use TLS to prevent users' passwords (and session cookies) from being intercepted.
    Getting a certificate is free with Let's Encrypt and setup should be relatively simple. Here's a guide from XenForo that should explain the process.
     
  2. Alex Dmitri

    Alex Dmitri Admin
    Staff Member Owner Contributor

    Joined:
    Feb 6, 2017
    Messages:
    79
    Likes Received:
    8
    I'm working on it. :)
     
    Coco likes this.
  3. Alex Dmitri

    Alex Dmitri Admin
    Staff Member Owner Contributor

    Joined:
    Feb 6, 2017
    Messages:
    79
    Likes Received:
    8
    Done :)
     
    Coco likes this.
  4. Coco

    Coco New Member
    Contributor

    Joined:
    Feb 11, 2017
    Messages:
    8
    Likes Received:
    1
    Nice, that was quick! :)
     
  5. Alex Dmitri

    Alex Dmitri Admin
    Staff Member Owner Contributor

    Joined:
    Feb 6, 2017
    Messages:
    79
    Likes Received:
    8
    Your personal details are safe now.
     
    Coco likes this.
  6. Coco

    Coco New Member
    Contributor

    Joined:
    Feb 11, 2017
    Messages:
    8
    Likes Received:
    1
    Might I suggest also changing the URL for the favicon to HTTPS. It currently prevents Chrome (and probably other browsers) from showing a green lock in the address bar because of mixed content.

    Similar story for posts containing images hosted on plain HTTP; it will show a mixed-content warning. From a quick Google search, I gather that there's an option in XenForo to have images proxied through your own domain to prevent exactly that.
     
  7. Alex Dmitri

    Alex Dmitri Admin
    Staff Member Owner Contributor

    Joined:
    Feb 6, 2017
    Messages:
    79
    Likes Received:
    8
    I know these things. I just didn't have much time. I'll sort it out.
     
    tinyman392 and Coco like this.
  8. Coco

    Coco New Member
    Contributor

    Joined:
    Feb 11, 2017
    Messages:
    8
    Likes Received:
    1
    I see that it's now fixed. Thanks a lot! :)
     
    tinyman392 likes this.
  9. Alex Dmitri

    Alex Dmitri Admin
    Staff Member Owner Contributor

    Joined:
    Feb 6, 2017
    Messages:
    79
    Likes Received:
    8
    I've been testing it with chrome myself. I don't have IE but i'm sure it's okay.
     

Share This Page